Visualizer doesn't recognize audio from PlayOneShot()

Visualizer doesn't recognize audio from PlayOneShot()

PostPosted by edwon » Tue Aug 13, 2013 9:51 pm

Visualizer isn't reacting to any audio triggered by AudioSource.PlayOneShot() I have to use AudioSource.Play() instead.

This is forcing me to re-organize my audio sample system. Is there a way to have it recognize clips played using PlayOneShot() ?
edwon
 
Posts: 2
Joined: Tue Aug 13, 2013 9:49 pm

Re: Visualizer doesn't recognize audio from PlayOneShot()

PostPosted by AlteredReality » Wed Aug 14, 2013 8:29 pm

edwon wrote:Visualizer isn't reacting to any audio triggered by AudioSource.PlayOneShot() I have to use AudioSource.Play() instead.

This is forcing me to re-organize my audio sample system. Is there a way to have it recognize clips played using PlayOneShot() ?


Unfortunately, if its not working with PlayOneShot(), that seems like a bug with Unity. I use AudioSource.GetSpectrumData() for all visualization data. Sorry I can't be more helpful on this, but theres not much I can do in this case.

More info on the function: http://docs.unity3d.com/Documentation/S ... mData.html

Have you tried posting on the Unity forums to see anyone else is seeing this issue?
Andy - Altered Reality
AlteredReality
Site Admin
 
Posts: 118
Joined: Fri Jan 06, 2012 8:31 pm

Re: Visualizer doesn't recognize audio from PlayOneShot()

PostPosted by edwon » Tue Aug 20, 2013 12:02 am

That's really sad! I wish it could work, seems like it would make performance and organization better.
edwon
 
Posts: 2
Joined: Tue Aug 13, 2013 9:49 pm


Return to Questions and Discussion

Who is online

Users browsing this forum: No registered users and 1 guest


Style by Gokinstudio | Free forum hosting by ProphpBB | Software by phpBB | Report Abuse | Privacy
cron