Clash with NGUI

Clash with NGUI

PostPosted by sinmantky » Tue Sep 04, 2012 3:27 am

Hi

I just bought this asset and so far I like it. However, I have one bug to report.

I have NGUI inside my game (as wel as LocatorHUD), which uses a 2D camera to render the GUI parts. Whilst this NGUI is activated, the indicator of the script does not appear in the correct position in the game screen.

Is there a way to fix this?

Thanks in advance
sinmantky

P.S I'm not a programmer, so hacking the code is pretty much impossible for me...
sinmantky
 
Posts: 2
Joined: Tue Sep 04, 2012 3:19 am

Re: Clash with NGUI

PostPosted by AlteredReality » Tue Sep 04, 2012 3:06 pm

It seems like it is using the wrong camera. You could try renaming all instances of "Camera.current" to "Camera.main" in LocatorHud.cs. Let me know if that works for you.
Andy - Altered Reality
AlteredReality
Site Admin
 
Posts: 118
Joined: Fri Jan 06, 2012 8:31 pm

Re: Clash with NGUI

PostPosted by sinmantky » Wed Sep 05, 2012 4:18 am

Hi Andy

Thanks for the tip. Have searched+replaced all 20 or so instances inside the cs file, and is now working ok.
I also had to set the main camera manually, as I have 3 or 4 so camera running at the same time.

Thanks!
sinmantky
 
Posts: 2
Joined: Tue Sep 04, 2012 3:19 am

Re: Clash with NGUI

PostPosted by AlteredReality » Wed Sep 05, 2012 11:13 pm

Cool, no problem! Glad to know it's working ok for you! :D
Andy - Altered Reality
AlteredReality
Site Admin
 
Posts: 118
Joined: Fri Jan 06, 2012 8:31 pm


Return to Locator HUD

Who is online

Users browsing this forum: No registered users and 0 guests


Style by Gokinstudio | Free forum hosting by ProphpBB | Software by phpBB | Report Abuse | Privacy
cron